Can't compile new App templates in Android Studio


#1

Hi

Does anyone know how to solve the following error when trying to compile any of the new Estimote app templates in Android studios, for instance Proximity for Multiple Beacons. I have tried both Java and Kotlin versions, but it always shows “Error: java.util.concurrent.ExecutionException: com.android.tools.aapt2.Aapt2Exception: AAPT2 error”

Does anyone know how to resolve this so that I can build the APK files?


#2

Can you let us know:

  • your Android Studio version
  • click File => Project Structure => Project; what does Gradle version and Android Plugin Version say?

I tested Proximity for multiple beacons on Android Studio 3.1.3, and with the default Gradle configuration that comes with the example (Gradle 4.1, plugin 3.0.1), on a macOS, and it worked for me.