Beacon in an undetectable state

#1

I was setting up one of my Proximity Beacons with the Estimote Proxmity Demo on iOS, when it got in to a bad state and became undetectable.

The beacon has been blinking at 1-second intervals ever since, and there doesn’t seem to be a way to fix it either in the Estimote app or from Estimote Cloud.

Could someone fix my beacon for me? It’s the “ice” beacon.

@heypiotr knows my account.

#2

It’s fixed now. Does the beacon just time out after a while?

#3

The beacons blink when they’re connected to. I supposed what happened is, the Proximity Demo connected to your beacon to check that it has the right configuration, then something went wrong, but the app was still left connected to the beacon. And since right now most Estimote Beacons can only be connected to from one device at a time, that made it “invisible” to the demo and the radar. After a while, your smartphone disconnected from the beacon, and so the problem fixed “itself”.

To be more specific, the beacon stops broadcasting its Connectivity packet if it’s already in connected state. All the other advertisements still work, but the radar & the Proximity Demo rely at least in part on the Connectivity packet.

#4

I was able to reproduce the conditions that put a beacon in to an undetectable state with iOS latest on an iPhone X.

Just tap “Claim” really fast as soon as you’re in the configuration screen of a particular beacon, then exit really quickly. The beacon will remain in blinking setup mode. The easy way to reset it is to put the phone in to airplane mode.

Your software should mention this fix inline so customers don’t get stuck.

Also I’m unable to claim any of the UWB Location Beacons that I just received, because they’re owned by someone with an @estimote.com email address. Could someone fix this for me?

#5

Should be fixed now!